SCCM OSD – “A required device isn’t connected or cannot be accessed”

sccm 600x400

We today ran into an issue where our SCCM OSD PXE boot was not working. It was coming up with a very confusing message stating:

“A required device isn’t connected or cannot be accessed”


This led us to start looking at the hard drive and the drivers, however, the solution was completely different.

The problem was that the RamDiskTFTPBlockSize we were using on our distribution point was too high, so we had to lower it to the Microsoft default.

To do this, you should follow these steps:

  • Go into regedit on your distribution point server
  • Browse to HLMSOFTWAREMicrosoftSMSDP
  • Find the RamDiskTFTPBlockSize key
  • Edit the decimal to “1456”
  • Close regedit
You should then retry your PXE boot sequence and you should find that it now works.

COMMENTS

If you have any questions or comments on this guide then please feel free to leave us a message below using our comments system.

Free Subscription

If you want to be notified when we post more quality guides like this one, sign up to our free subscription service and you will receive an email when a new post is live.

Join 105 other subscribers

No need to worry, we will not be filling your inbox with spam and you can unsubscribe anytime you like.

About A.J. Armstrong

Founder of TechyGeeksHome and Head Editor for over eight years! IT expert in multiple areas for over 20 years. Sharing experience and knowledge whenever possible! Making IT Happen.

View all posts by A.J. Armstrong

3 Comments on “SCCM OSD – “A required device isn’t connected or cannot be accessed””

Leave us a message...

This site uses Akismet to reduce spam. Learn how your comment data is processed.